Teraz jest niedziela, 16 czerwca 2019, 18:57

Strefa czasowa: UTC + 1




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 15 ] 
Autor Wiadomość
 Tytuł: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: piątek, 31 maja 2019, 22:31 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
Koledzy, ktoś ostatnio poruszał tu temat wyskakującego błędu niedogrzania głowicy w przypadku zastosowania jednego czujnika temperatury przy dwóch extruderach i sobie z nim poradził.
Za groma nie mogę namierzyć, gdzie przydziela się piny czujnika do dwóch extruderów. W zakładce pins.h nie znalazłem.

Edit: Już znalazłem, w pins_RAMPS.h w Temperature Sensors - ustawiłem na tych samych pinach 13.
Pozostało mi teraz tylko sprawdzić czy nie wywali jakiegoś błędu.

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: niedziela, 9 czerwca 2019, 16:09 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
Rzućcie okiem i uchem, proszę, na mój film na YT. Bardzo piszczą silniki extruderów i nie wiem czy tak ma być, czy gdzieś jest przyczyna. Trochę to uciążliwe dla uszu.

Vref ustawiłem na 0,99 V, bo tak podobno ma być dla silnika 0,9A jeśli rezystory stepsticka są R220. Tak przynajmniej tłumaczone jest na tym filmie

A może powodem jest metalowe mocowanie do ramy?

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: niedziela, 9 czerwca 2019, 16:44 
Offline
modelarz
Avatar użytkownika

Dołączył(a): poniedziałek, 25 stycznia 2016, 13:16
Posty: 2569
Wiek: 53
Lokalizacja: Winnica k/Pułtuska
Wymień stepstik na LV 8729, i nastanie cisza.

_________________
Pozdrawiam, Artur


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: niedziela, 9 czerwca 2019, 16:51 
Offline
Moderator
Avatar użytkownika

Dołączył(a): czwartek, 12 kwietnia 2012, 10:46
Posty: 5022
Wiek: 41
Lokalizacja: Kraków
Ten pisk pojawia się tylko co jakiś czas, więc pewnie jest związany z określoną komendą GCODE. Wysyłaj po kolei ręcznie komendy aż znajdziesz właściwy (piszczący) kod i wtedy będziesz wiedział więcej, luz zmniejsz vref i zobacz co się stało.

_________________
pozdrawiam
Hubert
https://www.banggood.com/?p=WQ230911983820130156


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: niedziela, 9 czerwca 2019, 17:05 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
Artur, extrudery mają właśnie LV 8729.
Pisk pojawia się przy retrakcji i podczas wycofywania filamentu podczas zmiany. Prędkość retrakcji 50 mm/s, wycofanie przy zmianie 100 mm/s.
https://youtu.be/RwieGX7YO-g

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 10:42 
Offline
modelarz
Avatar użytkownika

Dołączył(a): wtorek, 3 stycznia 2017, 09:32
Posty: 439
Wiek: 37
Lokalizacja: Warszawa
Jakie masz silniki? Prąd ustawiony pod silnik?

Ja miałem piski/dziwne dźwięki na ekstruderze na moich tanich silnikach 1.3A. Po zmianie na mocniejsze 1.7A problem się rozwiązał.
Zauważyłem że na małej prędkości pracują OK, ale dla wysokich już nie.
1. Zmniejsz prędkości do max 40mm/sec i zobacz czy też piszczy
2. Wymień stepstick na standardowy A4988 i zobacz czy też piszczy.

Czytałem gdzieś (chyba na forum reprapowo) że niektóre kombinacje sterownik/silnik źle pracują. Rozchodzi się o rezystancję i induktancję cewek. Niestety pozostaje zmiana sterownika lub silnika aby stworzyć dobrą parę.

_________________
Pozdrawiam
Przemek


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 12:50 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
Na mniejszych prędkościach też piszczy. Zmniejszać nie chcę, ponieważ przy zmianie filamentów chcę zminimalizować czas oczekiwania, bo jest 100 mm w przód i tył.
Chyba gdzieś mi się przewraca A4988 to sprawdzę.
Silniczki to "Anetowe" 0,9A https://pl.aliexpress.com/item/3D-cz-ci ... 5c0fOQ1y45
Innych na razie nie mam.
Dziękuję za sugestie.

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 13:43 
Offline
modelarz
Avatar użytkownika

Dołączył(a): wtorek, 3 stycznia 2017, 09:32
Posty: 439
Wiek: 37
Lokalizacja: Warszawa
Ja wiem że się nie chce. Mi tez się nie chciało :P ale wkurzenie i irytacja wygrały z nie-chciejstwem i suma summarum wymieniłem g-niane silniki na lepsze i problem się rozwiązał.

Czy przy takim dużym prądzie silniki Ci się nie grzeją? Gdzieś czytałem że powinno się ustawić 70% wartości nominalnej - czyli dla 0.9A trzeba dać 0.63A.

_________________
Pozdrawiam
Przemek


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 14:10 
Offline
Moderator
Avatar użytkownika

Dołączył(a): sobota, 20 marca 2010, 17:47
Posty: 5835
Wiek: 47
Lokalizacja: Józefów (ten koło Błonia)
Mam ustawione 50mm/s w obie strony i wysuw 4mm.

_________________
Lynx Oxy 4

Pozdrawiam Adam


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 14:17 
Offline
modelarz
Avatar użytkownika

Dołączył(a): wtorek, 3 stycznia 2017, 09:32
Posty: 439
Wiek: 37
Lokalizacja: Warszawa
Osa napisał(a):
Mam ustawione 50mm/s w obie strony i wysuw 4mm.


To przy zwykłym układzie. Kolega Piotr ma układ dwukolorowy i tam trzeba sporo filamentu wysunąć i wsunąć przy zmianie koloru.

_________________
Pozdrawiam
Przemek


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 14:39 
Offline
Moderator
Avatar użytkownika

Dołączył(a): sobota, 20 marca 2010, 17:47
Posty: 5835
Wiek: 47
Lokalizacja: Józefów (ten koło Błonia)
A to sorry.

Wysłane z mojego Redmi Note 4 przy użyciu Tapatalka

_________________
Lynx Oxy 4

Pozdrawiam Adam


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 15:26 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
japim napisał(a):
Czy przy takim dużym prądzie silniki Ci się nie grzeją? Gdzieś czytałem że powinno się ustawić 70% wartości nominalnej - czyli dla 0.9A trzeba dać 0.63A.


Po 4 godzinach wydruku silniki extruderów są lekko ciepłe. Ale sprawdzę na niższym napięciu. Te 0,63 które podałeś, to pewnie miało być napięcie mierzone na potencjometrze?
Co do silników, to te lepsze to jakie? Proszę o przykłady ze sklepów :) Mogę zaryzykować do 100 zł/szt

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 18:19 
Offline
modelarz
Avatar użytkownika

Dołączył(a): wtorek, 3 stycznia 2017, 09:32
Posty: 439
Wiek: 37
Lokalizacja: Warszawa
Piotr_G napisał(a):
japim napisał(a):
Czy przy takim dużym prądzie silniki Ci się nie grzeją? Gdzieś czytałem że powinno się ustawić 70% wartości nominalnej - czyli dla 0.9A trzeba dać 0.63A.


Po 4 godzinach wydruku silniki extruderów są lekko ciepłe. Ale sprawdzę na niższym napięciu. Te 0,63 które podałeś, to pewnie miało być napięcie mierzone na potencjometrze?
Co do silników, to te lepsze to jakie? Proszę o przykłady ze sklepów :) Mogę zaryzykować do 100 zł/szt
]

0.63A na silniku musisz sobie przeliczyć na V na stepsticku. Nie wiem jakie Mas rezystory 110 czy 220Ohm.

Silniki takie: https://blackfrog.pl/silnik-krokowy-nem ... p-214.html jak kupisz wysyłkowo i nie podpasuja to możesz odesłać.

_________________
Pozdrawiam
Przemek


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: poniedziałek, 10 czerwca 2019, 20:20 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
Założyłem przed chwilą dwie sztuki TMC2208, tak jak na osiach XYZ i nastała błoga cisza. Słuchać jedynie wentylatory. Podrukuję trochę i sprawdzę czy nie wyjdą jakieś kwiatki.

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
 Tytuł: Re: MKS GEN L v1.0 - dwa extrudery i jeden hotend
PostNapisane: środa, 12 czerwca 2019, 16:38 
Offline
modelarz
Avatar użytkownika

Dołączył(a): sobota, 3 kwietnia 2010, 19:10
Posty: 1624
Wiek: 45
Lokalizacja: Braniewo
Wczoraj wieczorem wydrukowałem łódeczkę z gotowego projektu, i albo to wina drukarki, albo programu tnącego lub projektu, bo nie do końca jestem zadowolony. Niebieski jet mocno poszarpany :(
Filamenty PLA są tej samej firmy, extrudery mają te same ustawienia w slicerze.
Spróbuję jeszcze zrobić kalibrację i pomierzyć czy w rzeczywistości pobierają tyle samo filamentu.
Załącznik:
BY1.jpg
BY1.jpg [ 444.24 KiB | Przeglądane 65 razy ]

Załącznik:
BY2.jpg
BY2.jpg [ 447.63 KiB | Przeglądane 65 razy ]

Załącznik:
BenchyIM.jpg
BenchyIM.jpg [ 151.97 KiB | Przeglądane 65 razy ]

_________________
moja strona firmowa: https://gprofi.pl


Góra
 Zobacz profil Wyślij e-mail  
 
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 15 ] 

Strefa czasowa: UTC + 1


Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów
Nie możesz dodawać załączników

Szukaj:
Skocz do:  

67,205,783 Wyświetlone Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Przyjazne użytkownikom polskie wsparcie phpBB3 - phpBB3.PL